You are browsing the archive for webconsole.

Avatar of alkin

by alkin

Diagram view not working in the webconsole OpsMgr 2007 R2: “missing permissions on the server allow the creation of the RenderBase and/or ImageCache folder”

12:50 pm in Uncategorized by alkin

Today I ran into the following problem: I was unable to access diagram views from the webconsole. Every other view like a state view, performance view, alert view etc was working but not the diagram view:

 

clip_image002

Likely this is due to missing permissions on the server allow the creation of the RenderBase and/or ImageCache folder or the ability to create files in these folders. Either add the permissions for the anonymous INET user to write to the root folder, or create the RenderBase and/or ImageCache folder and in the root of the web application and add write access to these folders.

 

As you can see the temp folder is empty

 

clip_image004

you need to give the group called IIS_IUSRS read and write permissions to the root folder of the webconsole

image

once done you will see the following files being created in the temp folder:

clip_image005

and now the final test!

clip_image007

woohoo it’s working! :-)

 

And now you will see a PNG file in the temp folder for every diagram view you open. That’s why you need to modify the rights so that the group IIS_USRS can add those PNG files to the temp folder.

image

I don’t think this is very efficient. Image a NOC with 10 guys consulting the webconsole and each one of them opens 2 views and with 4 levels each then you will 80 PNG files in the temp folder!! But that’s a total different discussion :-)

 

Hope this helps,

Alexandre Verkinderen

Avatar of alkin

by alkin

OpsMgr Webconsole Runtime error “Server Error in ‘/’ Application”

8:07 pm in Uncategorized by alkin

Just a little reminder that if you install the OpsMgr web console after the UI console has already been installed you will need to Copy the following files from the %Program Files%\System Center Operations Manager 2007 directory to the %Program Files%\System Center Operations Manager 2007\Web Console\Bin directory:

 

  • Corgent.Diagramming.CommandResources.dll
  • Corgent.Diagramming.CustomElements.dll
  • Microsoft.ReportViewer.Common.dll
  • Microsoft.ReportViewer.Webforms.dll

 

Otherwise you will get the following error when launching the webconsole:

clip_image001[4]

 

Hope this helps,

Alexandre Verkinderen

Visit Us On TwitterVisit Us On Linkedin