DPM 2010: Upgrade from beta to RC

February 10, 2010 at 3:43 pm in Uncategorized by mikeresseler

Hey All,

Download of the DPM 2010 RC is finished, uploaded to my test server so here goes:

Documentation?

First thing noticed, there is no documentation with it so I will have to do it with the older documentation from the beta.  Not so good since there are additional features in the RC and I was hoping on reading about it.

So I figured I just start and see where I get :-)

Installation

image

Ah, maybe here is some information… So let’s try it out.  I’ve looked at Review System Requirements,View Release Notes and Read Setup Help but they all pointed to DPM 2007 information.  So let’s go for the Install Data Protection Manager link then.

image

First error, so let’s fix this first.  Apparently I was still working with the CTP version of Windows Powershell 2.0 so I had to remove it first.

Second try.

image

image

Since I uninstalled Powershell, the intstallation wizard is enabling it now.  This takes a long time… but finally

image

image

Of course, protection jobs cannot run during the upgrade and you need to upgrade your agents immediately afterwards but this you get each time you do an upgrade with DPM.  Press Next to continue

So the prerequisite checker is running, and I seem to be not passed

image

So here are my prerequisites missing:

KB 962975: Dynamic Disks are marked as “Invalid” on a computer that is running Windows Server 2008 or Windows Vista when you bring the disks online, take the disks offline, or restart the computer if Data Protection Manager is installed.

KB 975759: An application or service that uses a file system filter driver may experience function failure on a computer that is running Windows Vista, Windows Server 2003, or Windows Server 2008

and finally Windows Management Framework Core package (Windows PowerShell 2.0 and WinRM 2.0)

A reboot is needed, so we will have to start from scratch again.  Lessons learnt, take these hotfixes with you when you need to install DPM 2010

So I ran back through my setup and came back to the prerequisites screen

image

Now everything is ok so let’s continue

image

Since I am upgrading, and the installation used to had a dedicated SQL instance, I will reuse it

image

Give the password for the local accounts that will be used.

image

Choose whether you want to use the Microsoft Update or not

image

Customer improvement experience can’t be changed during the RC, this will be possible in the RTM version of course

image

image

 

image

Upgrade has been successfully… but I have a warning tab, so let’s read

image

Seems logical :-)

Allright, let’s start the console and go to management.

image

I need to update an agent

image

The same warning that you always receive when upgrading something. Any running jobs will fail, and you need to do a consistency check afterwards

image 

A big difference between 2007 is that I didn’t had to run through a wizard.  I just clicked OK on the warning and the upgrade starts.

This is the error that you get when you have an agent with a previous version

image

image 

The upgrade however failed

image

According to the newsgroups, I wasn’t the only one with this problem.  After a while (the second time) it worked.

New Agent Version

image

The new agent version is now 3.0.7558.0

Cheers,

Mike