Error code “0x800F0906” when you try to install the .NET Framework 3.5 in Windows 8 or in Windows Server 2012

June 27, 2013 at 6:16 am in Uncategorized by Kenny Buntinx [MVP]

 

In Windows 8 and in Windows Server 2012, the .Net Framework 3.5 is a Feature on Demand. The metadata for Features on Demand are included in Windows 8 and in Windows Server 2012. However, the binaries and other files associated with the feature are not included. When you enable the feature, Windows tries to contact Windows Update to download the missing information to install the feature.

This behavior can also be caused by System Center Configuration Manager who configures the computer to use Windows Server Update Services (WSUS) instead of the Microsoft Windows Update server for patching. When the case you will see “Error code: 0x800F0906” appearing

In this case, enable the Specify settings for optional component installation and component repair Group Policy setting and configure the Alternate source file path value or select the Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS) option.

To do that configure the Group Policy setting and follow these steps:

  1. Start the Local Group Policy Editor or Group Policy Management Console.

     

  2. Expand Computer Configuration, expand Administrative Templates, and then select System.

     

  3. Open the Specify settings for optional component installation and component repair Group Policy setting, and then select Enabled.

     

 

Hope it Helps ,

Kenny Buntinx

Tweet about this on TwitterShare on FacebookShare on Google+Share on LinkedInPin on Pinterest