SCOM 2012: Webconsole fails to load after upgrade

September 25, 2011 at 9:15 pm in Uncategorized by Dieter Wijckmans

In my recent session I’ve showcased an error I encountered when upgrading my SCOM2007R2 environment to SCOM2012beta.

After the upgrade was finished successful I performed my standard after migration health check and opened my web console to check out the new features of the SCOM 2012 console.

Only to find out this very “nice” cryptic error message:

printscreen0050

Apparently this is because the ASP.NET version was installed after the IIS role and the new web app “SCOM 2012 Web Console” was never registered to use this version of ASP.NET with the IIS role.

So what are we going to do now… well euhm… Fix it Smile

Open an elevated command prompt (make it a habit, this will save you a lot of trouble in your live)

printscreen0051

Open explorer and browse to “c:\windows\Microsoft.net\Framework64\v4.0.30319\”

Note: Make sure you use your installed framwork and version

printscreen0052

Locate the file aspnet_regiis.exe and drag it into your elevated command prompt and add the switch –iru at the end as shown below. printscreen0053

This actually will reinstall the ASP.NET version into the IIS sites so they can all use the new version. Sites which already use the new version are left untouched.printscreen0054

Finished installing… So we’ll see what happened to our console!

printscreen0055

Well it’s loading up fine at this point Smile

Note: You’ll need to have Silverlight installed. If you don’t have it on your machine a nice kind message will appear whether you want to install it. I’ve installed it in advance as it is one of the prerequisites.

printscreen0056

There we have our nice brand new shiny Scom 2012 web console which we can start exploring Smile

Share on FacebookTweet about this on TwitterShare on Google+Share on RedditShare on LinkedIn